State Locking

Is something not working the way you expect? Enter it here because someone else might have a similar issue.
timssewell
Posts: 29
Joined: Mon Aug 19, 2013 8:40 am

State Locking

Postby timssewell » Mon Aug 26, 2013 11:53 am

Hi

Not sure how to describe this, but here it goes.

First Enter Test mode.
I have an container (C1) that on hover triggers a state, which shows another container (C2), and when you move the mouse off C1 the opposite state is triggered automatically and C2 disappears. This all works fine most of time time, but quite often the off state doesn't get triggered which leaves you with C2 visible, and from then on the only way to fix it is to exit test mode, go to C2 and toggle the visibility. When this happens no states seems to get triggered when hovering on/off C1 at all.

Hope that makes some sense.

Thanks
Tim

Nick Jennings
Posts: 165
Joined: Mon May 14, 2012 12:06 pm

Re: State Locking

Postby Nick Jennings » Mon Aug 26, 2013 3:40 pm

Hi,

Do you know if the direction you move the mouse off has any affect on the visibility? It may be that the mouse is hovering over something and it causes some type of error that makes the state not change. You could try copying the two containers and putting them onto a different design to see if it happens there.

You may also want to try clearing your cache to see if it is an issue with stale cache.

If the problem persists, please send us an e-mail with your domain, project and page where the contains are so that we can test it out ourselves.


Return to “Troubleshooting & Bug Reports”

Who is online

Users browsing this forum: No registered users and 2 guests

cron